AnsweredAssumed Answered

How do you get Maplex to recognize character spacing?

Question asked by rjzehnder on Sep 19, 2017
Latest reply on Aug 9, 2018 by mboeringa2010

From Esri help:

"The character spacing text formatting tag is ignored by the Maplex Label Engine. Character spacing must be set in the text symbol to be respected."

 

I am specifying negative character spacing in the text symbol (i.e. not using text formatting tags, just as the help says to do) for labels using Maplex Label Engine, but it is not being reflected in the labels.  It works fine with the standard label engine, but I need to use Maplex for the project.

Potential workarounds:

  • Use the Maplex spread characters option with a negative value.  This doesn't work because it doesn't allow negative values.
  • Use the standard label engine for this feature class and Maplex only for the ones that need it.  This doesn't work using labels because the label engine is specified at the map document level.
  • Use the standard label engine to label these features, then convert those labels to annotation and switch to Maplex for the remaining labels.  This is my last resort, and I'm hoping someone has a better solution.

 

Note this only happens with negative character spacing; Maplex does respect the text symbol character spacing if it is positive.

 

I am using ArcGIS 10.5.1 Desktop Advanced (version 10.5.1.7333).

Outcomes