AnsweredAssumed Answered

why won't my Survey123 results send? No error, just stuck on attachments

Question asked by nmt22 on Aug 25, 2017
Latest reply on Oct 26, 2017 by JTedrick-esristaff

First, my setup:

-ArcGIS Enterprise 10.5 (Workgroup Advanced with 5 portal users) Base-Installation (portal, server, datastore) hosted on a single Azure

-Survey123 App for Android v2.3.29 (though previous versions did this as well) on ASUS MeMo Pad 7 and Lenovo Yoga Tab 3 8" devices (as well as a handful of iPhones, and various moto and samsung phones, depends on what my crew has on hand any given day)

-publishing results to the Hosted Feature Service that was created when I first published this survey from Survey123 Connect

 

What happens:

My users spend 1-3 days offline collecting data on a form that includes up to 2x places for photos. When they return, they connect to WiFi and initiate sending from their tablet. Without failure, at least one (typically many) of the 12 tablets simply gets stuck at "adding attachment 1 of..." (1 or 2, its not consistent). When I say stuck, I mean hours can go by, days even (weekend), without an error message or a change in state of the app or dialog. If I tap the back button, I'm returned to the form's main page, there may be a handful of items that made it through, and there are still a number of unsent items in the outbox. Here's the kicker... when I open the survey that was stuck, and locate the questions with the image(s), there is no thumbnail, but there is a filename for the associated image. If I simply delete the image (tap the little x button) and resend, that form will upload, and maybe 50% of the time the very next record gets stuck just the same. 

 

What I've tried:

Initially, I thought maybe the internet connection and subsequent bottleneck of 5 to 8 devices uploading might be the issues. I've instructed and maintained that crew should only upload one tablet at a time... no difference... I've even taken tablets to a known high-speed WiFi connection at home (75mbps down / 25mbps up) and tried one-by-one to no avail. Sometimes they stick, sometimes they go....

Then I caught wind that some of my crew believed they were able to take multiple photos per question (not the case, there are 2x separate questions for photos without any repeat group). They indicated they would take one photo, then click the camera button again and take another. I've tried to recreate this, but of course it works fine when I do it, I simply end up submitting the last photo I took successfully... 

 

I'm lost at this point... has anyone else experienced this? Am I missing something entirely? Thanks everyone for your help!

Outcomes