AnsweredAssumed Answered

"Unable to register the ArcGIS Server with the Web Adaptor. Please make sure that the server machine is running..."

Question asked by zhe_yyc on Aug 16, 2017
Latest reply on Oct 26, 2018 by inghamn

Note: The variable names shown in the format <variable> are fake values for security purposes. All others are their actual values.

 

I just finished doing fresh installs of ArcGIS Server, Portal, and Web Adaptor on our Ubuntu 16.04 LTS server machine. All 3 installs were done at version 10.5.1. I'm now trying to configure Web Adaptor for both the Server and Portal, but I'm getting stuck on the configurewebadaptor.sh script command, which is giving me the following error message (I get the same error message if I use the web GUI too):

 

"Unable to register the ArcGIS Server with the Web Adaptor. Please make sure that the server machine is running and that the account specified has administrative privileges to the site."

 

I'm running the following command on the host machine "<hostname>" through an SSH session:

 

./configurewebadaptor.sh -m server -w http://localhost/server/webadaptor -g http://<apple>.<banana>.<tld>:6080 -a false -u admin -p <abc123>

 

Everything that I'm passing to the script is valid. I've configured a Tomcat server to run on the host machine on port 80 & 443 to serve up the "arcgis.war" file to both "/server" and "/portal", and I can access "/server" at http://<apple>.<banana>.<tld>/server/webadaptor, although it gives me the "The web adaptor configuration URL has to be accessed from the machine hosting the web adaptor" splash screen, hence why I pass the URL with domain "localhost" in the command above.

 

The host machine's /etc/hosts file is as follows:

 

127.0.0.1     localhost

<host_IP>    <apple>.<banana>.<tld>    <hostname>

 

Similarly, http://<apple>.<banana>.<tld>:6080 is a valid, running ArcGIS Server instance, with a default admin account set up with the username "admin" and password "<abc123>".

 

Where's the problem?

Outcomes