AnsweredAssumed Answered

Can publish GP Service but cannot run it on ArcGIS Server 10.5.1

Question asked by jread79 on Aug 7, 2017
Latest reply on Aug 18, 2017 by jread79

I have a GP tool that I had no issue running on ArcGIS Server 10.3.1, but when trying to setup the service on a 10.5.1 machine, I am running into an issue that I've been unable to resolve:

 

The tool runs in ArcMap fine and publishes successfully, but when I run it I get the following error:

 

Error 000732 Network: Dataset ______ does not exist or is not supported.

 

I thought that for some reason the arcgis user could not access the folder, so I gave it permissions on the entire C:\arcgisserver directory

 

That did not fix it, so I navigated to the copied .SDE connection file in ArcCatalog at: C:\arcgisserver\directories\arcgissystem\arcgisinput\Tool.GPServer\extracted\v101\connection.sde

 

I was able to connect and view the data with no issues.

 

So then I tried a simpler tool that just lists the feature classes in a geometric network. Same issue. I noticed in the error, though, that it is automatically stripping out the "Database.SchemaOwner" heading on the data. I manually entered these back in and the tool worked.

 

Going back to the first tool, I noticed the same thing. The tool is looking for this and failing:

 

\connection.sde\FeatureDataset\Network_Net

 

When it is supposed to be looking for:

 

\connection.sde\Database.SchemaOwner.FeatureDataset\Database.SchemaOwner.Network_Net

 

Why is it stripping these values out? It seems to do this on its own without me telling it to. I even went into the extracted copy of the python script and explicitly added the paths into the code, and it is still doing this at runtime anyway. Since it is doing this, it cannot find the data it is looking for and thus failing to run.

Outcomes