adamczi

PCA Image Classification tool produces actual background data

Discussion created by adamczi on Aug 5, 2017
Latest reply on Aug 6, 2017 by adamczi

This might be a simple question, but I can't find a way to fix it. After creating a Principal Components image from Image Classification toolbar, I get a red fill around the image up to a size of a square in which the image could be fitted in - see image1 attached. The problem is these are not some NoData areas, but regular values: in this case R: 65535, G: 0, B: 0 (or different solid color, depending on order of bands in composite bands menu).

 

I can try setting "Display background value:(R, G, B)" to "No fill", but it just doesn't show the color, but the values are still there. This will surely affect my analyses.

 

While creating the PC image saw in Environments, that Raster Storage -> NoData = NONE is set by default. I also set processing extent to the extent of one of supplying rasters (from which none have those strange background fill, because they are Landsat bands). I tried to input a composite of 7 bands into the tool or each band individually, both with same result of this background fill.

 

Important: when executing the tool into Default.gdb it works fine! Only with any other custom location it gets crazy. I read about this kind of a bug with exporting rasters, but I think this case if different.

 

Is there any way to get rid of it without having to clip the raster?

Using latest build of ArcMap 10.5.

 

 

P.S. I'm sorry if this is not the appropriate space to post it - I couldn't find a better one.

Attachments

Outcomes