AnsweredAssumed Answered

Some Zonal Statistics (Raster) outputs do not match Zonal statistics table values and are negative?

Question asked by kateballard on Jul 20, 2017
Latest reply on Dec 13, 2017 by xander_bakker

I have a county shapefile that I am using as the "zones" and a raster dataset of landcover types. I extracted each type of landcover, making it so that each one had an individual raster (so water raster, Deciduous forest raster etc). Then I performed the Zonal Statistic as Table tool and summed up the number of pixels of a certain type in each county. It seems to have worked correctly. Now I am trying to use the Zonal Statistics tool to give me an output raster that represents those same SUM values, but it seems that some of the outputs for certain zones are wrong. There are some zones (counties) that match their SUM values in the original Zonal table, and then some that are negative and do not match their value in the table.

For example, when I use the Identify tool and click on the county (zone) #27071 it tells me that the value for the SUM generated by the Zonal Statistics tool was -739109312.0. I checked to see what the Zonal Statistics as TABLE tool assigned as the SUM value for county #27071 and it was 1770032 (completely different). This number should not be negative to begin with, and I checked to make sure the original raster didn't have a value like -999 assigned to it for "No Data" cells, and it did not (it actually had nothing assigned for No Data). In addition, I told the tool to ignore No Data cells. This happened for multiple counties. 

However, some of the counties did match the original Zonal Table SUM values, so it seems like the tool is doing something weird for only some of the zones? 

Does anyone have any idea what could be going on? 

Thank you very much for your help, 

Kate 

Outcomes