AnsweredAssumed Answered

Building Mosaic in Weighted Overlay Service Toolbox for GeoPlanner doesn't work

Question asked by MAGI_linda.menk on Jul 9, 2017
Latest reply on Jul 24, 2017 by rstauder-esristaff

For a project in university I’m supposed to create a #Weighted Overlay Service for geoplanner for arcgis. I’m using ArcGIS for Desktop 10.4.1 and the #Weighted Raster Overlay Service Toolbox which I downloaded from Github for my data preprocessing.

The last step of the preprocessing I’m supposed to use the Build Mosaic Dataset tool, which fails to execute. I don’t know what the error message means.

What I did so far on all my datasets is:

1. Clip them to my Area of Interest.

2. Project them to Web Mercator Auxiliary Sphere.

3. Check and Repair Geometry.

4. Calculate Euclidean Distance (Because I want to figure out spaces within my city which are close to Kindergartens, Schools, Playgrounds, but far from highly frequented roads). By using the Calculate Euclidean Distance tool, my data is transformed from vector to raster.

  • I made sure that in my Environment Settings the Processing Extent and the cell size was the same for every layer.

5. Next, I performed Calculate Statistics for my Area of Interest

6. To handle NoData cells, I used the Raster calculator where I entered e.g. the expression Con(IsNull("EucDistKinder"),9999,"EucDistKinder"), to exchange NoData values to 9999.

7. Then I used Raster to Other Format to convert my layers to geoTIFF.

 

After that comes the difficulty:

I’m supposed to use the #Configure Raster Fields tool, from the Weighted Raster Overlay Service toolbox. I shall enter Input ranges by the pattern min. value included, max. value excluded (0,201,201,401...). This range should match my classification, but as you can see in the image, ArcMap shows me that my ranges go from 0 to 200, and then the next class starts at 200 too.

Is this also displayed as min. included, max. excluded? Plus, it is labeled as starting from 200,0000001. As I can only enter whole numbers in the Input Range I want my classification to go from 0 to 200 and then from 201 to 400. Is there a way I can force ArcMap to classify like that? Because I think that might be the reason why I can’t build a Mosaic Dataset in the end.

As I already spent ages figuring out my mistakes, I would be super glad if someone could help me or recommend documentation except for https://doc.arcgis.com/en/geoplanner/documentation/use-your-data.htm, which I’m currently using as my guide.

Thank you a lot,

Linda

Outcomes