AnsweredAssumed Answered

Editing script tool issues

Question asked by ElizabethB_SantaRosaGIS on Jun 27, 2017
Latest reply on Jun 28, 2017 by ElizabethB_SantaRosaGIS

I'm having difficulty getting a consistent result with editing a script tool.  Here's the situation: I downloaded the Fire Run Map Book solution from the ESRI solutions page, and need to edit one of the scripts named "Create Street Index Report".  (I'm trying to do some minor edits to cause the streetname field to wordwrap, instead of running into the page number column).  After hours of searching online, I have followed the advice of others and installed PythonWin 32, build 219, and set that as my script tool editor in the Geoprocessing Options tab. The ESRI Support tech referred me to this link Editing script tool code—Help | ArcGIS for Desktop  and I have been attempting to use that workflow. 

 

I am able to right click the tool and choose edit, and PythonWin opens the script. However there's where things get murky.  When I make a change to the tool, and click the save icon, the Save As box opens, which isn't what I need. On Friday, I tried the exact same workflow, and it worked correctly - I was able to right click, make a few changes (STILL can't get the street names the way I want them!), do a save, run the tool, and voila- my changes were in the finished product.

 

Since I am still trying to get the street names formatted in a readable fashion, I am continuing to work on this. Yesterday and today, back to the same problem - PythonWin prompts me to do a save as, so the edits I make are not showing up in the final product. I cannot figure out why I am able to edit it some days and not on others.  Any ideas? I am using ArcGIS 10.5, and the version on the ESRI solutions page is also 10.5.

Outcomes