AnsweredAssumed Answered

Feature Service Not Editable in Collector

Question asked by adrienmroth on Jun 8, 2017
Latest reply on Jun 8, 2017 by adrienmroth

Hi, let me start by saying I've already read through a number of threads on here with similar issues, and tried the suggestions provided to no avail. 

 

My set-up is this: I have a feature service published to ArcGIS Server containing one feature class that I wish to use for offline editing with attachments, being consumed by AGOL.  The SDE feature class in the feature service has been registered as versioned and contains GlobalIDs.  The file does not currently contain any records, as it's the intention that the data will be collected in the field.  I am using an Android platform for the Collector app.  In the Collector app, I am able to a) sign in to the organizational AGOL account, b) view the map and c) open the map.  Upon opening the map, though, there isn't any '+ Create Features' icon/button, and when I click on 'Layers' I see my feature class, but it is grayed out and I am unable to check it. 

 

Some additional info for troubleshooting I have tried:

1) I have unregistered the data as versioned and turned on all of the Feature Service Capabilities (Create, Delete, Query, Sync and Update) and received an error message saying that the feature class wasn't configured for Sync capabilities

2) I have re-registered the data as versioned leaving all of the Feature Service Capabilities turned on (Create, Delete, Query, Sync and Update) and received an error message saying that the Service Capabilities weren't properly configured for use with Sync. 

3) I read online in Esri documentation that if the data is versioned you should only leave the Query and Sync Capabilities turned on, and if the data is unversioned to turn all of the Capabilities on (Create, Delete, Query, Sync and Update).  I want to be able to use this feature class offline for data editing and collection with attachments, which to me, dictates that it must be versioned???  So the documentation seems contradictory. 

 

Help, please!

Attachments

Outcomes