AnsweredAssumed Answered

Error 001359: Failed to connect to the server

Question asked by apurvdanke on Apr 13, 2017
Latest reply on Apr 18, 2017 by apurvdanke

Hi,

 

I am using ArcGIS Desktop and ArcGIS Server 10.4.1. I have spent many hours trying to find a solution for this. The background to this issue is that I want to publish an MXD which refers to raster data in mosaic datasets. This data is going to be stored in a network drive on another server to which we have read-write access but no access to that server itself (such as RDP access or Administrator access). Previously we were using a local account "arcgis" to run the ArcGIS Server service. This account was created during installation. So when we had this local account, we were able to work with mosaic datasets because the raster data was stored in another server where we had remote and administrator access. So we had created a local "arcgis" user with the same password on that server, so that the raster data is accessible to ArcGIS Server on the other server through UNC path.

 

The problem is that now we have got a much bigger network share to store the raster data, but as per the policies we cannot have a local "arcgis" user created on that server. So to work around this problem I found that we can use domain account to run ArcGIS Server instead of local account, and ensure that the domain account has access to the network share which has all the raster data. So using the "Configure ArcGIS Server Account" utility I have changed that account to a domain account, and it has permissions to read the data from the new network share. I have also registered the geodatabase connection and the network share folder in ArcGIS Server. So when I try to "Analyze" the MXD it does not show any errors or warnings. But I'm getting the error message below while publishing.

 

 

I also have web adaptor installed on the same machine as ArcGIS Server so that services are accessible through IIS. I have tried a lot of things such as ->

 

1. Restarting the ArcGIS Server service after configuring with the new domain account.

2. Restarting the server.

3. Removing the local "arcgis" user from the server and again configuring the domain account using the utility and restarting the ArcGIS Server service.

4. Created a role "GIS Administrator" in ArcGIS Server Manager and created a user and assigned the user to that role.

5. Created a new connection in ArcCatalog with this new user and tried to publish the service.

6. Changed the service security for PublishingTools service to "Public, available to everyone".

7. Created a new connection in ArcCatalog using web adaptor URL in this format : http://<hostname>/arcgis

8. Saved a service definition file and then tried to publish the map service using ArcGIS Server Manager. I get the following screen for an eternity.

 

 

Nothing has worked for me. Even if I try to publish vector data in the MXD I'm unable to. Can someone please suggest solution for this?

 

Regards,

Apurv

Outcomes