jamesfreddyc

ArcObjects in ArcGIS Desktop 9.3.1 and 10

Discussion created by jamesfreddyc on Jan 3, 2011
Latest reply on Feb 10, 2011 by AlBowe
Ok, I am having diffiuclty locating an answer on this and hope someone could help.  I have several applications that I maintain/support across an organizations IT infrastructure, all are developed with .NET Framewrok 3.5 SP1 and are all ICommand/ITooblar interfaces that run in ArcGIS Desktop 9.3/9.3.1 versions.

Will these need modification to be installed with ArcGIS Desktop 10?

1.  Will I need to bind these components to ArcGIS? For ex, will I need to include:

'Insert this line before invoking any ArcObjects to bind Engine runtime.
ESRI.ArcGIS.RuntimeManager.Bind(ESRI.ArcGIS.ProductCode.Desktop)


2.  Will my existing Setup.exe packages still function?  Do they need modification?

Thanks for any input.

james

Outcomes