AnsweredAssumed Answered

WAB adds basemap from web map automatically to widget

Question asked by Gdi_bx on Mar 29, 2017

Hello there,

 

I have built a Web Map using two layers as basemap: the esri world light gray base und above it my own basemap (city map, in german: "Stadtplan")  from an ArcGIS Server Service. This is working fine.

Out of that I bulit a Web App with Web App Builder and added the "Basemap Gallery Widget".

 

What I want: When starting the app, the basemap used in the web map is shown and when I open the "Basemap Gallery Widget" I want to have the choice between "Stadtplan" (city map) and "Luftbild" (arial photo). 

 

What I did: I added the two basemaps into the widget ... "Luftbild" and Stadtplan". I did that because I wanted to add a self generated small picture for the Stadtplan-basemap and not the automatically generated that comes up, if I only add the arial-photo as basemap.

 

The esri help website for this widget tells me "If the basemap used in the web map is not included during the configuration, it will be added automatically when the widget opens."

This, the other way around, means to me: If I do add the the basemap used in the web map manually into the widget, it will NOT be added automatically.

 

But this is what happens: When I open the widget it shows me three basemap to choose from.... the arial-photo (left), the city-map (middle) and the city-map generated out of the web map (right). 

 

What I could do: Delete the manually generated basemap "city-map" from the widget (middle in the picture).

 

Why don't I? Because I don't like the look of the automatically generated picture, because it does not just show the basemap, but the basemap with the content of the webmap above it. 

 

So I want to delete the automatically out of the web map generated basemap out of the "basemap gallery widget".

 

I hope this explanation was understandable... 

 

Has someone any idea how to fix this problem?

Outcomes