nsridb

Advice required upgrading Oracle with ArcSDE

Discussion created by nsridb on Mar 22, 2017
Latest reply on Mar 23, 2017 by jesdial

Problem: We want to upgrade our Oracle 11g + ArcSDE 10.1.0 to Oracle 12c + ArcSDE 10.4.1

 

Steps tried so far:

  1. Created a new virtual server
  2. Exported a full database backup from current Oracle 11g
  3. installed Oracle 12c to new server
  4. from an ArcGIS 10.4.1 client used python to create ST_GEOMETRY as described here: http://desktop.arcgis.com/en/arcmap/10.3/tools/data-management-toolbox/create-spatial-type.htm
  5. imported full backup from oracle 12c
  6. from ArcGIS 10.4.1 client connected to new server using TNSNAMES.ora to define connection
  7. connected to geodatabase using ArcCatalog unfortunately all spatial tables were identified by a default icon and not the relevant spatial type icon. Right clicking on object would update icon but if loaded into ArcGIS it would put up a “New Query Layer” form and ask the user to identify a Unique Identified Field, then calculate extent.
  8. Raster datatype not recognised at all, so installed ST_RASTER type and reloaded raster files from backup, unfortunately they are still not recognised as rasters. Direct copy/pasting the rasters from the original geodatabase to the new one using ArcGIS client works but this would need to be done by every user/schema that owns rasters to maintain ownership.
  9. Noticed the new SDE.LAYERS table is empty except for the table directly loaded using copy/paste.

 

Can anyone advise what we are doing wrong and what steps we are missing.

Thanks in advance

Outcomes