AnsweredAssumed Answered

Copy Features Model Builder - Error 000840

Question asked by pprendergast@my.uri.edu on Feb 22, 2017
Latest reply on Feb 23, 2017 by jayanta.poddar

Hello,

 

I am trying to automate a long process in model builder and I am having trouble with one of the steps. I have the ArcGIS 10.2.2 student software and I am trying to run the following model:

 

I know there is a lot there, but the part I am having trouble with involves selecting by attributes from a feature, making a layer, and then copying the features so I then do some more geoprocessing (dissolve, etc.). The model works great until I get to the "Copy Features" tool which spits out the following error:

Failed to execute. Parameters are not valid.
ERROR 000840: The value is not a Feature Layer.
ERROR 000840: The value is not a Raster Catalog Layer.
Failed to execute (Copy Features).

Just for kicks, I tried the "Create Feature Class" and "Feature Class to Feature Class" tools and I get the same error message.

 

I am really baffled here because I broke up this model into smaller components and ran the following model that starts after the "Script" tool in my other picture and the "Copy Features" tool works just fine:

 

I need the first model to work, however, because I need to use an early output in a geoprocessing step later (I just haven't incorporated that step into the model yet).

 

Any help would be greatly appreciated. Let me know if I should post any other helpful information.

 

Thanks,

Pat

Outcomes