AnsweredAssumed Answered

Are GP services useless on ArcGIS server with versioned data?

Question asked by rvangilst on Jan 19, 2017
Latest reply on Oct 11, 2018 by rvangilst

The setup:

  • Versioned data in an SQL Server database
  • GP service that connects directly to the SDE data.

 

Running my service the first time is fine, and the service responds as I expect.

Make an update to the data the GP service uses, either via ArcMap or by using a feature service on the same data.

Running the service the second time, returns the same result at running it the first time (if the service is just reading data, when editing it will just fail).

 

The service "hangs" in the state the version had the first time it ran. And there does not seem to be a programmatic equivalent to "Refresh version" as there is in ArcMap. 

 

Our Danish distributor says that this is "by design", but I cannot accept this to be true, can it?

 

The easiest way to reproduce this is to create a model that returns the count of a feature class and publish this to ArcGIS server. Then run the service, add or remove a feature, than run the service again.

 

My real problem is that I have to update features in multiple feature classes in a GP service, look at the result, make some changes, and run the GP service again. Then I run into error when updating, because the version that the GP services runs in is outdated.

 

I hope someone has a solution for me.

 

Friendly regards,

 

Robert

Outcomes