AnsweredAssumed Answered

Visual Studio 2010 Ultimate not seeing SDK

Question asked by evtguy on Jan 5, 2017
Latest reply on Jan 12, 2017 by tburgan

I feel like such a noob again. Anyways, several years ago, I got my feet wet with .NET add-ins for Arcmap using Visual Studio 2008 Express. Fast forward to today when I need to troubleshoot why my add-in isn't working. My current PC is Windows 7 64-bit with ArcGIS 10.4.1 and Visual Studio 2010 Ultimate. The ArcObjects SDK for .NET appears to be installed on my machine (I have tried a repair on the install).

 

I tried opening up my old 2008 project and it said it needed to migrate it. Fine. It completes without throwing an error. When I attempt to build/rebuild the project, I get 100s of errors that the ESRI objects are not defined. When I look at My Project, I see that all the ESRI references are broken:

 

 

If I try to create a new project, ESRI Add-ins are not listed on the lefthand side:

 

 

So- I'm guessing there's something wrong with my install? Something installed out of sequence or...? I can't seem to find anything in the online help about SETTING UP the SDK; only creating an add-in once the SDK is installed.

 

Thanks!

Steve

Outcomes