AnsweredAssumed Answered

ArcGIS 10.5 and Data Interoperability FME version

Question asked by vanporman on Jan 5, 2017
Latest reply on Nov 27, 2018 by adrienmroth


In our client machine, we have upgraded ArcGIS Server to 10.5 (previously, it was 10.2.2). We also have a list of FME converters (created by ArcGIS Data Interoperability tool), FME converters are then saved as tools with ArcGIS Model Builder and a python script runs those converters every week. After the upgrade to 10.5, python script stopped working with various error messages:


#! TITIE=""




"Traceback (most recent call last):
File "C:\Data\INSPIRE_data_update\SCRIPTID\", line 24, in <module>
File "C:\Data\INSPIRE_data_update\Konverterid.tbx", line 87, in Vaheandmebaas
ExecuteError: Failed to execute. Parameters are not valid.
ERROR 000816: The tool is not valid.
Failed to execute (Vaheandmebaas)."

There messages apper to come randomly, no logic that we could find.

With the ArcGIS 10.5 version, the Data Interoperability version is also 10.5, but the FME version there is 2016.1.2
Python version is 2.7.12

The thing is, that those models, if started manually inside ArcCatalog toolbox, work perfectly.

As I understand, ArcGIS 10.5 needs FME 2016.1.3.

Could it be a version conflict between ArcGIS 10.5 and FME version inside ArcGIS Data Interoperability 2016.1.2?

Or python version problem?

If 10.5 needs FME 2016.1.3, then why hasn't ArcGIS Data Interoperability 10.5 have a FME 2016.1.3 version?