AnsweredAssumed Answered

Publishing Issues ERROR 001369 & 001487 & 001488

Question asked by Daryl.Hochhalter on Dec 15, 2016
Latest reply on Jun 22, 2017 by Daryl.Hochhalter

ArcGIS 10.4, ArcServer 10.4, Federated Portal 10.4, SQL Server 2014 Geodatabase

All these errors give the message Packaging Succeeded, but publishing failed. Yesterday I was getting 001488, and eventually solved the problem by creating a new MXD and copying the layers into it, I was able to publish. This morning I noticed one layer in an already published service wasn't drawing in the web map I added it to. I tried to re-publish the Service and got Errors 001487 & 001369, same error message I was getting yesterday with the other number. I tried a number of things again including creating a new MXD. Nothing worked until I removed the server account privileges from a particular Dataset and then gave the same privileges back to it again. I was then able to re-publish the service.

 

So my question is what could cause a layer in a service to quit drawing, finally requiring the action I took to remove privileges and reinstate them? Is it possible that if I had renamed one of the Feature layers in the Dataset after initially publishing, this it what it took to fix it?

Outcomes