AnsweredAssumed Answered

Application ID in the index.html file is ignored

Question asked by VojtaBlazek on Dec 2, 2016
Latest reply on Jan 26, 2017 by OEvans-esristaff

Hi I know, this question were discused many times, but I didnt find a solution.

 

I made a story map journal :

http://blazek.maps.arcgis.com/apps/MapJournal/index.html?appid=23cf12230c264896aa369f72f2d6f11d 

 

Everything works perfect. Then I want to run this app without any changes on my web server http://studio-vojta.czweb.org/ 

I downloaded a zip file from GIThub -> unzip -> change index.html -> upload to my web server

 

And stil an error (mistake) - google translate:

"An error has occurred
The URL parameters is not specified identifier Web mapping application (? = AppID). In development mode is to configure the application ID in the index.html file is ignored."

but in index.html is ID of app:

var configOptions = {
// Enter an application ID created through the Map Journal builder
appid: "23cf12230c264896aa369f72f2d6f11d",
// Optionally to secure Journal's access, use an OAuth application ID (example: 6gyOg377fLUhUk6f)
// User will need to sign-in to access the viewer even if your application is public
oAuthAppId: "",
// Optionally, to use the appid URL parameter, configure authorizedOwners to reference
// members whose stories can be viewed by this storytelling app.
// To authorize stories owned by...
// specific members: use ["member"] or ["member1", "member2", ...]
// any ArcGIS member: use ["*"]
// any member of one or more organizations: use ["[orgID]"] or ["[orgID1]", "[orgID2]", ...] (Note the use of brackets in this case, e.g., ["[nzS0F0zdNLvs7nc8]"])
// You can get your orgID by going to My Organization and clicking Find...The most viewed items in the organization.
// Your orgID will be shown in the search box.
authorizedOwners: [""]
};

What do I wrong? Thanks

Files on my web

Attachments

Outcomes