AnsweredAssumed Answered

Portal 10.5-pre Portal Initial Admin Creation Hangs Indefinitely

Question asked by damon.m.cook on Nov 22, 2016
Latest reply on Jan 13, 2017 by tornadotianya

Quick Context Reference:

Product:  Portal for ArcGIS

Release Version:  ArcGIS Enterprise (Linux) Prerelease 10.5

Server OS:  Red Hat Enterprise Linux Server release 6.8

Web Browser Used:  Firefox

Other products installed:  ArcGIS Server with GeoEvent, ArcGIS Datastore, and WebAdaptor

 

Hello,

 

I am running into an issue with similar (but not identical) behavior to Portal 10.3 Configuration Settings but without the configuration change that the user of that topic had made.  The core issue I am running into is that I cannot complete the portal site/admin-user creation.  After I reach the "Account Created" pop up then click [OK], Portal will load forever as it attempts to reach a resource that 404's on the backend.

 

I am installing from scratch on Linux using the silent install with a .prvc provisioning file for authorization.  I have already attempted uninstalling, deleting any remnants, and reinstalling several times and I am not tweaking any of the configuration files in between the process.  My install process has been (Omitting some paths for privacy):

su - arcgis

cd ~/tmp/PortalForArcGIS

./Setup -m silent -l yes -a /path/to/portal.prvc

After the Silent install I can verify the license is properly loaded with:

~/arcgis/portal/tools/authorizeSoftware -s

After the install, the portal process will be running.  I've been skipping the step of copying over the SysV service scripts for now (this has worked fine in the past) and accessing our server at the url (replacing portal.domain.com with the Fully Qualified Domain Name of our portal server):

https://portal.domain.com:7443/arcgis/home 

When first accessing this page, it comes up as expected and I'm offered the choice between creating a new portal or joining an existing one.  I chose to create a new site then fill in a Name, Email, and Username/Password for the initial admin user and click okay.  This spins for a bit but then loads as expected into one final page:

 

Account Created, last working page before eternal spin

 

Up to this point, everything will install normally, as expected.  But it's when I click [OK] on this "Account Created" page that the portal page will then go into an endless loading loop.

 

Pulling up the debug window on the side I can see a repeating call to an /arcgis/sharing endpoint that will wait, then fail with 404 before spinning up another attempt.  This process does not appear to timeout:

404 Errors

 

This is where the behavior ends up similar to Portal 10.3 Configuration Settings.  To quote some tests from a user from that issue that produce the same result for me:

If i try /arcgis/home renders an empty page

if i try /arcgis/sharing - page not found

To append to this, /arcgis/portaladmin will actually come up for me, but I cannot log in with the user I created.  Some of the utility scripts that portal come with also seem to suggest that the username I entered was somehow created, but cannot be used to authenticate in anyway.

 

In my case, I haven't fiddled with the "WebContextURL" property anywhere nor have I tampered with the postgres database at all.  This issue occurs on a clean install and is repeatable.

 

Thoughts?

Outcomes