AnsweredAssumed Answered

How do I force Maplex to ignore transparent polygons, not ignore Data Frames?

Question asked by ethan.warren@dot.ny.gov on Sep 21, 2016
Latest reply on Nov 6, 2016 by OZGeo

Currently, I'm using Maplex Label Engine in ArcMap to label a map of New York State. It works pretty well so far, but I haven't been able to figure out how to do two things: to get it to ignore the transparent layers, and to not ignore other data frames. I know I can just turn the labels into annotations and place them how I like, but I'm trying to make the production of these maps as automated as possible.

 

Ignore transparent polygons

I'm using transparent polygons laid over top of my map to separate regions of the state. You'll see below here with Oneida Lake that the label goes right up to the black boundary of the transparent grey polygon, even though I have things set so it should try to fill the polygon. 

 

I've also tried things like increasing the font size to preposterous levels in orders to make sure that it is regarding the grey polygon boundary as a hard limit. There's no way to get the label to cross the border without making it look ridiculous. I've done everything that I can find within Maplex to force it to cross the boundary. I'll list the settings, maybe someone can point out what I can do better. I think the solution is probably outside of Maplex, though. I just don't know where.

 

Label Position:

Regular Placement (Don't avoid polygon holes)

 

Try horizontal position first checked

Position: Curved

Anchor Points: Geometric center of unclipped polygon (then eroded center)

Spread words and characters both checked (infinite limit)

 

Fitting Strategy:

Stack Label checked

Overrun Feature checked

Strategy order: Reduce label in size, Stack, Compress width, Overrun, Abbreviate

I tried unchecking all these, but that didn't help, and obviously screwed up all my other labels.

 

Conflict Resolution:

Interior feature weight: 0

Boundary feature weight: 0

Background label checked (or unchecked, nothing changes)

Never remove checked

 

Don't ignore data frames

I have inset maps laid over my main map in the print layout, as seen below. They are data frames, but as you can see, labels don't seem to give other data frames any regard. LAKE ONTARIO is reduced to ARIO.

 

It looks like this issue has been brought to ESRI before. I saw one item posted in the Ideas section to just add an item to the Weights section in Conflict Resolution, which sounds like the obvious, easy solution. But in the mean time, is there a less obvious, frustrating solution?

Outcomes