AnsweredAssumed Answered

Arcobject sdk system requirements

Question asked by s.sorvillo@almaviva.it on Sep 13, 2016
Latest reply on Sep 14, 2016 by FGibson-esristaff

I'm trying to use ArcObjects SDK for Java, on my machine I have windows 10 , eclipse and java jdk 1.8 all 64bit .

 

At initialization of the license back to me this error : "Could not load native libraries . java.lang.UnsatisfiedLinkError : C : \ Program Files ( x86 ) \ ArcGIS \ Engine10.3 \ bin \ ntvinv.dll : Can not load IA 32 -bit .dll on AMD 64 -bit platform " .

 

My Code is:

 

EngineInitializer.initializeEngine ( );

AoInitialize aoInit = null;
try {
   aoInit = new AoInitialize();
} catch (UnknownHostException e) {
/ / TODO Auto-generated catch block
    e.printStackTrace();
} catch (IOException e) {
// TODO Auto-generated catch block
    e.printStackTrace();
}

 

Thanks arcobjects-sdk 10.3.1 

Outcomes