AnsweredAssumed Answered

Issues registering geodb in AWS

Question asked by wdtadmin on Sep 8, 2016
Latest reply on Sep 9, 2016 by wdtadmin

We are setting up a stack in AWS for our GIS services. We have two boxes functioning as sitehost boxes that are clustered, two web adaptors, and a box that publishes services. The problem we're having is that everything comes up great, the site is created via my scripts, the second sitehost joins the first site and they exist as a cluster, and the web adaptors register great. The problem comes when publishing. When we run the publishing script, and attempt to register a Geodatabase connection as well as a few folders, it won't register. Which then the service publishing fails. I've tried multiple things where i disconnect web adaptors, disconnect cluster nodes, etc, and nothing works. It still refuses to add the datastores. We are using the standard arcpy modules to add the datastores, and the folders are on a network share, but we know the syntax is correct. It worked once on our first build with this AMI (ami-02704168) and it registered, however, the next build (where the only thing that changed was it downloaded an extra MXD) it failed to register. This has been occurring with the old AMI (back from feb) which is why we switched to the new 10.4.1 AMI.

 

Also of interest is that when I try and pull up the logs from the cluster "master" I get this
"ArcGIS Server Manager

Unable to query for logs on '10.100.68.17'. Could not connect to server on machine '10.100.68.17'. ArcGIS Server on that machine may not be running or the machine is not reachable at this time."

Also consistent with both times we've had issues, we can't register folders or DBs manually through the server manager. It just sits and spins and nothing registers.

 

Which is interesting. Is my sitehost having issues? 

Outcomes