AnsweredAssumed Answered

Feature not being sent on device. However, it was sent multiple times.

Question asked by KurtHa on Aug 31, 2016
Latest reply on Sep 7, 2016 by MidnightYell2003

I made a survey for a couple of Users at work.  Not too complicated, just some calculations, external choices, and relevant questions.  The Users wanted 4 photos per survey.  I didn't use the photos as a repeat.

 

The Users went out into the field with an iPad and were in some pretty good canopy, which gave them some points that were off.  Meaning the connection was poor.  They tried to send the surveys and got errors on a number of them. 

 

They brought the device in and we hooked up to the WiFi.  I had them sign in and out a number of times as we tried to send the surveys.  They seemed to be getting hung up on "image 3 of 4 loading."

 

I went back in to try to edit a few of the records on the device and 2 of the images were missing on each of these records.  Pretty weird.

 

Went into the feature service and could see that most of the records were loaded multiple times with 2 of 4 attachments.  They had different Global IDs, so thank goodness put a unique ID field in there so I could tell which ones were the same.

 

Do you know of any issues with adding more than 2 images to a record?  Also, from a data management standpoint, this seemed pretty sketchy with the loading of the same record multiple times.  How is the User supposed to know the record loaded if the device says there was an error when loading?

 

I like the application and see a lot of potential, but this was concerning. 

Outcomes