AnsweredAssumed Answered

Kafka and Rabbit MQ transport components not working in 10.4.1 Linux

Question asked by lraeDCGSN on Aug 29, 2016

Hi - Am running arcsever, arcportal and geoevent 10.4.1 in RHEL 6.x    Most sample adaptors/connectors deploy -  IRC, COT, etc.   kafka and RabbitMQ local transport components say they deploy, but do not show up in connector list (like IRC and COT does).

When I import the kafka_config.xml in the configuration store, error message says that it cannot find the transport

 

Import configuration completed with errors. Imported the connector 'kafka-text-out', however the the transport 'com.esri.geoevent.transport.outbound/Kafka/10.4.1' is invalid (it probably doesnt exist). Imported the connector 'kafka-text-in', however the the transport 'com.esri.geoevent.transport.inbound/Kafka/10.4.1' is invalid (it probably doesnt exist).

Following the instructions in zip file at:  

http://www.arcgis.com/home/item.html?id=7f94ec2a3eb944c79e98fe854d60d671

 

having same issue when I try to deploy rabbit mq adaptor.

 

Seeking help...!

Outcomes