AnsweredAssumed Answered

Invalid redirect_uri 400 error in operations dashboard

Question asked by sviva.gov.il on Aug 25, 2016
Latest reply on Aug 25, 2016 by sviva.gov.il

Hello,
I created my first Operations Dashboard item to demonstrate and share others in our organization the benifits of it.
Sadly, it just stopped working without any clear reason.

 

I have operations dashboard installed localy and it works perfectly fine.
After creating my desired webmap, I saved it as a portal item, giving it full access premissions. Then, I created another item as an application, which refers to the url where you get to see the Operations Dashboard view in a browser, rather than an installation window.

 

It actually worked perfectly fine for a few days! Seeing my result in a browser, playing with the widgets and all.. Just when I decided to share it with my proejct manager I get this horrible error when trying to run it again in the web browser.

 

The process of opening the portal item is as follow -
1. Seeing the Operations Dashboard logo as a loading screen
2. Black screen with a white square inside, containing the error message.

I've attached some screenshots.

I tried searching for answers in google, geonet, esri's resources.. nothing comes up.
Going through the different settings screens didn't helped much either.

 

Fiddler just shows an invalid url response from the address -
https://[MACHINE_NAME]/portal/sharing/rest/oauth2/authorize?client_id=arcgisoperationsdashboardweb&display=iframe&response_type=token&expiration=20160&redirect_uri=http%3A%2F%[MACHINE_NAME]%2Fportal%2Fapps%2Fdashboard%2FpostSignIn.html&parent=http%3A%2F%[MACHINE_NAME]&persist=true&locale=en&force_login=true

 

even when I try going to the base address with no params it gives the same error message of a bad resource -
https://[MACHINE_NAME]/portal/sharing/rest/oauth2/authorize

 

The portal Item opens the following address which probably "hosts" the app and tries to access it first with AuthO2 somehow -
http://[MACHINE_NAME]/portal/apps/dashboard/index.html#/ab7bad3cb4f14316b7e6721c8c8ad2c4

 


At that point I am clueless Anyone knows anything about this issue?


Kind regards,
Shay.

Outcomes