AnsweredAssumed Answered

ArcGIS 10.4. Problem with add-ins backward compatibility

Question asked by APerlov on Aug 5, 2016
Latest reply on Sep 9, 2016 by egbunse


Hello everyone. I have a problem with backward compatibility with ArcGis Desktop 10.4 and .NET add-ins built for earlier versions of ArcGIS Desktop.

 

I have a .NET add-in built for ArcGIS Desktop 10.3.1. When I try to install add-in by double-clicking add-in file, i get the message "Installation succeeded", but add-in does not appear in  add-in manager dialog. In fact, add-in succesfully installs only in a second attempt. If i try to install add-in using Customise -> Add from file, i get error message:

"No GUI components found in this Add-In.

Add-In version does not match."

 

When I try to install add-in built for ArcGIS 10.4 on ArcGIS 10.4.1 I get the same problem.

 

Al i want is to build add-in for ArcGIS 10.3.1 which would be normally installed on 10.4, 10.4.1 and later versions of ArcGIS desktop. Can anyone help me to solve this problem?

Outcomes