AnsweredAssumed Answered

What's up with my choice_filters? HELP!?!

Question asked by colgateg on Aug 2, 2016
Latest reply on Aug 2, 2016 by colgateg

So this is our 30th or so survey we have created and up until now the choice_lists have been working pretty well. In this particular inspection there are two separate sets of cascading choice_lists... the first list works fine: tee type filters tee manufacturer which filters tee model and so on. The second set for valve information doesn't work at all.

 

In the User interface, it presents like the value selected for valve type never gets passed to filter valve manufacturer, so the choice filter essentially filters out all of the values. But in the diagnostic log, it looks like the form is trying to change values on the wrong column (see log file attached).

Some of the troubleshooting we've already gone over:

  • Removed the choice filters. The result was each select_one fields were populated with every value from their related choice_list. As expected.
  • Removed the "Tee" fields completely from inspection. The result was the "valve" fields worked as expected. The choice_filters worked without any modification. Reintroducing the "tee" fields to the inspection recreated the problem.
  • Created several new inspections with canned data and all the choice filters worked. Created a new inspection with the same data as the one that is failing (from scratch/no copying) and the problem was again present.
  • Swapped out all of the choice list values for canned data. The problem persists.
  • Change all of the field names, list names, filter names. The problem persists.

 

We repeated our tests in iOS, Windows 7, and Android. The problem only exists in the iOS client.

 

What are we missing?

Outcomes