AnsweredAssumed Answered

ArcGIS Server Manager 10.4- can't figure it out

Question asked by t.faull on Jul 18, 2016
Latest reply on Jul 26, 2016 by deleted-user-CQZbjNeBXm49

Ok so at our company we use ArcGIS for Server 10.0. you host layers as a service and set the MXD it should read from (?). You then create a web map application that allows you to view the layers in a browser-based map, with search and query functions (tasks). The data you see on this map directly reflects the underlying GIS data held on our servers. So if I edit a polygon shapefile in ArcMap, the server web map will show this change (just referesh the view extent or reload the page in the web map). This has worked OK for us over the years.

 

Now we've moving to ArcGIS for Server 10.4. The interface is quite different and I'm a bit lost. I'll show you what I've done, and what my problems are:

 

I open the 10.4 ArcMap mxd with the layers and view extent I essentially want replicated in the ArcGIS for Server software-

 

File > Share As>Service

From here on, I try leave things as default as I'm unfamiliar with most of the terminology...

The service name is unchanged, to match the name of the MXD:

I save the .sd service definition file in a folder I have R/W access to.

 

I now analyze the map. No errors returned, 2 high warnings however:

I don't think I'll be needing KML functionality, so I turn it off. This removes the KML high warning after another Analyze map.

 

I now click 'Stage':

 

This successfully creates the .sd file:

So far, so good.

 

I open the Server Manager 10.4 interface and log in:

 

Publish Service seems to be the most obvious choice here to upload my .sd file and get things rolling:

Keeping things default for now:

Next screen I click publish. After a bit of waiting, a green success bar appears briefly! The tumbnail appears to confirm all has worked and I now have a webmap to view and share:

 

I click Edit serivce just to mull over the options I have available. I eventually leave everything at default. I'm sure it's all fine and ready to go. I do however changed some text in the summary box on the Item Description tab:

I click 'Save and Restart'... An Error appears. But why? I only changed a bit of text, and the .sd filepublished without error earlier. The service started without issues too. Now when restarted, this came up:

I have no idea what the error means. The 'Authority_boundaries' layer it refers to is a simple polygon file with 5 or 6 shapes.

Anyway, the error says the service has started regardless. I click 'Manage Services' to navigate back to the services list. I click on the 'view' button that appears above the thumbail when hovered over with the cursor:

This is my resulting screen:

Blank. No layer list. No basemap choice. No searching functionality. Zooming in and out does nothing.What have I done wrong? Thanks for being patient if you got this far!

 

What i wanted to see was something similar to our ArcGIS for Server 10.0 interface and webmap:

I've covered the content with a green box for confidentiality reasons...

This interface has a list of layers on the left I can toggle on/off.

Several attribute table search tasks on the top left, with a results panel that accompanies it.

Simple interaction tools on the top right.

It directly reflects an MXD we have created which defines the layer symbologies and view extent etc.

 

I want these back in 10.4! Not much of an 'upgrade' at the moment!

Outcomes