AnsweredAssumed Answered

GEOProcessing Service Data Access Questions (10.4.1)

Question asked by mcieri on Jun 29, 2016
Latest reply on Jul 18, 2016 by rastrauch


Hi,

I am trying to move a geoprocessing tool from ArcGIS 10.1 to 10.4.1.  I moved everything over from the old server and was able to publish the service without any errors (and run the model from 10.4.1 Desktop) but when i run the service i get the

 

ERROR 000004: Could not get the address fields.

 

This error is coming from the record set variable that allows a user to enter an address or addresses.  I can't seem to figure out why ArcGIS Server can't access a variable that is in memory.

 

****ADDED Record Set from Rest Service everything looks correct***

    "displayFieldName": "", "fields": [ { "name": "OID", "type": "esriFieldTypeOID", "alias": "OID" }, { "name": "ADDRESS_1", "type": "esriFieldTypeString", "alias": "ADDRESS_1", "length": 100 }, { "name": "ADDRESS_2", "type": "esriFieldTypeString", "alias": "ADDRESS_2", "length": 2 }, { "name": "CITY", "type": "esriFieldTypeString", "alias": "CITY", "length": 50 }, { "name": "STATE", "type": "esriFieldTypeString", "alias": "STATE", "length": 50 }, { "name": "ZIP5", "type": "esriFieldTypeString", "alias": "ZIP5", "length": 10 }, { "name": "ZIP4", "type": "esriFieldTypeString", "alias": "ZIP4", "length": 4 } ], "features": [ {"attributes": { "OID": 1, "ADDRESS_1": "123 MAIN ST", "ADDRESS_2": " ", "CITY": "ANYWHERE", "STATE": " ", "ZIP5": "10001", "ZIP4": " " }}, {"attributes": { "OID": 2, "ADDRESS_1": "789 MIDDLE ST", "ADDRESS_2": " ", "CITY": "ANYHERE", "STATE": " ", "ZIP5": "99999", "ZIP4": " " }} ], "exceededTransferLimit": false }

 

Does anyone have any thoughts on why this maybe happening?

 

Thanks,

Matt

Outcomes