gabhvz2010

xml.etree disfunctions with ArcGIS10.0

Discussion created by gabhvz2010 on Dec 6, 2010
Latest reply on Dec 7, 2010 by gabhvz2010
Hi !

I'm currently trying to parse an xml file.
Pretty simple, the xml file is a file to store custom environment parameters. The xml is made within Arc by one of my other script, with xml.etree lib. From there, everything is fine, except when I use the same lib. to parse my xml and read a node within it.
In PythonWin, my code works, in an ArcToolbox, it works only if I run the code outside arc process, wich take an awfull lot of time.
I know and I've read about the fact that some libs could not work within arc process and that we should run it outside...but it's only a function within the same lib that doesn't work...I think it's a problem ESRI should debug.
Here the error that comes up when I run my script:
<type 'exceptions.ImportError'>:No module named expat; use SimpleXMLTreeBuilder instead

Has anyone encountered the same problem or could indicate me how to bypass that?

regards,

Gab

Outcomes