hillshade command producing odd results in arcpy for arcpro

Discussion created by skienast on Jun 23, 2016

I have written a stand alone script in python 3.4 that uses ArcPro arcpy to complete various geoprocessing tasks on a list of input DEMs. One of the tasks is a hillshade, which is usually very straightforward. When I run the script (below), I get a very odd result (attached as hillshade1), which defaults to display the hillshade as using the unique categories symbology when you open it in ArcPro. If I switch the symbology to stretched, it appears as expected (attached as hillshade2) so the correct data is there. Also, if I run hillshade in ArcPro using the geoprocessing tools, the results return a stretched default symbology as expected (as in hillshade2 below). I don't see any options in the code for the hillshade command that determine default symbology. In addition, this code ran fine previously as part of a stand alone script with python 2.7 and ArcGIS Desktop. What is the disconnect between running the tool in ArcPro and running it in a stand alone script using python 3.4 and the arcpy package? Is this a bug or is there something I can do in my code? Thanks!script_excerpt.JPG