AnsweredAssumed Answered

Can't Register table with Geodatabase - Arc 10.1, SQL 2008

Question asked by jmeyer198 on Jun 15, 2016
Latest reply on Jun 15, 2016 by jmeyer198

I have database that is named xytest and it contains multiple table of point and line features.  The database was created by a third party application.  In Arc Catalog Geodatabase has been enabled for the database.  When I right-click a table and go to Mangage, everything is greyed out and not available.  I looked in sql to verify I am using the correct login.  SQL show the owner of the database is xytest.  In SQL under the database->Security->Users the user 'dbo' is xytest.  If I perform a SELECT statement on dbo.SDE_layers the only item is GDB_ITEMS and it shows and owner of 'DBO'.  In Arc Catalog I have tried to login as the 'xytext' user and I am still unable to perform and functions under Manage.

 

I did notice on the table I am trying to register with the geodatabase the Schema is xyz2016Temp.  I have created another user in SQL and set the default schema to the xyz2016Temp.  I have added this user to the database server roles of sysadmin and processadmin.  I made sure the user is a db_owner of the database and has all permissions turned on.  The functions in Arc Catalog under Manage are still greyed out.  I am at a loss of what to try next. 

 

I have created databases in the past, Enabled Geodatabase and registered the tables with the geodatabase.  I created another database to test and it worked flawlessly.

 

I have verified there are no locks on the database.

 

Any help and suggested would be greatly appreciated.

Outcomes