AnsweredAssumed Answered

Pictures don't show in published story map (map tour)

Question asked by n.ueberschaeresri-rw-esridist Employee on Apr 30, 2016
Latest reply on May 3, 2016 by n.ueberschaeresri-rw-esridist

When putting my Story map together I had the references to the pictures and the thumbnails already correctly stored in my feature class that I uploaded to AGOL. Unfortunately for the big pictures the URLs were missing and were only saying something with "undefined?token=...." So I added the URLs manually for every single picture (which was annoying enough). All big pictures were showing after that process. After editing, saving and sharing the Story Map I opened it with the provided link and had to find my big pictures missing again. Opening it in edit mode was driving me almost mad now because I found the same link as before with "undefined?token=....."

 

Can please someone advise what I did wrong with my picture URL?

 

I have the pictures on my own website e.g. http://www.nicole-in-ruanda.de/wp-content/uploads/2016/04/20160423-120235_Dubai_Eingang_Internet_City.jpg for the big picture and http://www.nicole-in-ruanda.de/wp-content/uploads/2016/04/20160423-120235_Dubai_Eingang_Internet_City-150x150.jpg for the corresponding thumbnail. Both links are stored in my feature class but only the thumbnails showed up.

 

Just found this question Paths to pictures are not being saved. Paths to pictures keep being set to undefined after saving. as very similar to my problem. Somehow unfortunately I have in contrast to this posting a field called pict_url, and in the popup I defined in my map, the pictures show. At least I'm glad that the links are still there...

Outcomes