AnsweredAssumed Answered

Having trouble running Segement Mean Sift as Raster Function

Question asked by MervynLotter on Apr 27, 2016
Latest reply on May 2, 2016 by MervynLotter

Hi there

 

I have successfully done this once before, but that was some time back and now I am struggling to run Segment Mean Shift as a raster function. It works just fine as a geoprocessing tool.

 

I guess I am missing an important step in the raster edit function chaining process.

 

I tried running the segment mean shift function on Mosaic Datasets created for both Sentinel 2 and Landsat imagery and I have tried to run this function in both ArcMap 10.4 and Pro 1.2 (and it always fails - so problem must lie with my approach).

 

1. As the Segment Mean Shift process needs to run 3 band imagery, my first step was to use the Extract Bands function to tease out 3 bands.  The output pixel type was 16 Bit Unsigned.

 

2. I then used the Stretch function and Standard Deviation to apply an appropriate stretch to my image (the 3 extracted bands). The Output Minimum is 0 and Output Maximum is 255 and the Pixel type is set to 8 Bit Unsigned.

 

3. I use the Clip function to limit the extent of my analysis, ensuring the output pixel type is still 8 Bit Unsigned.

 

Up to this stage, the imagery displays correctly in my map view (stretched, clipped, etc).

 

4. I apply the Segment Mean Shift function on my output from the Clip function and the map display is blank (not showing any results from function chain). Running the Validate  while in Raster Function Editor does not display any problems.  My input Raster is <Clip.OutputRaster> and output pixel type is still 8 Bit Unsigned.

 

If I use the output of my Clip function in the Segment Mean Shift geoprocessing tool (not as a raster function), then it works.

 

I am guessing I have missed a step or a setting in my raster edit function chain. Any advice?

 

Thanks,

Mervyn

Outcomes