AnsweredAssumed Answered

HTTP/HTTPS problem in WAB 2.0

Question asked by lubojr on Apr 26, 2016
Latest reply on Apr 26, 2016 by lubojr

Hello,

I added a HTTP feature service layer into a Webmap that I am using in WAB. I saved and everything worked perfectly on WAB version 1.3, because WAB launched itself also in HTTP mode. Yesterday I tried to run the new 2.0 version and immediately hit a wall. After around 5 seconds console showed up a problem, that WAB cannot load the feature service because it runs in HTTPS mode, so the feature service present in the Webmap has to be also loaded through HTTPS.

I am also loading some .png pictures from internet sources in my widget through HTTP, which works just fine, only a warning shows up in console, that they should be loaded in HTTPS mode.

Since the feature services I added are not mine, I cannot rely on them being able to load through HTTPS. Is there a way to force WAB run in HTTP only? I tried to remove the "S" in adress bar, but it auto reloads again into HTTPS mode.

 

 

 

 

Thanks for help.

Lubomír

Outcomes