AnsweredAssumed Answered

ArcMap copying the default Python libraries like while publishing GPService in \v101\<toolbox_name> folder.

Question asked by ShreyaCh on Apr 17, 2016
Latest reply on Apr 18, 2016 by ShreyaCh

I am facing a strange issue since last 2 days. I am trying a publish a GP service containing a simple code to send an email to the provided userid using smtplib. The tool is running successfully and the email is being sent.

After the tool is published, when I am opening the folder

C:\arcgisserver\directories\arcgissystem\arcgisinput\<folder name>\<service_name>.GPServer\extracted
strangely I am finding a tilingservice.xml file.

And when I am opening the folder:
C:\arcgisserver\directories\arcgissystem\arcgisinput\<folder name>\<service_name>.GPServer\extracted\v101\<toolbox_name>
I found that has been copied !


I tried publishing the service from a ArcMap in a different server to mine this issue is not getting reproduced. But when I am publishing my from ArcMap in my laptop to any other server the same issue is getting reproduced.
I have tried deleting the Python27 folder and repairing it but this does not help.
Any help or leads is really appreciated.


Thanks in advance,