AnsweredAssumed Answered

SOLVED: Amazon PostgreSQL  RDS - Enable Enterprise Geodatabase crashes, using 10.4

Question asked by airobotics on Apr 6, 2016
Latest reply on Dec 20, 2016 by WSimonazziesriaustralia-com-au-esridist

Hi all,

I have two AWS machines set up and running:

EC2 with Windows 2012 - running ArcGIS for Server Enterprise Standard and ArcGIS for Desktop Standard 10.4.

RDS with PostgreSQL 9.4.5.


I have followed all the instructions shown here:

Create a geodatabase on Amazon Relational Database Service for PostgreSQL—ArcGIS for Server (10.4) | ArcGIS for Server


But I got stuck in stage 7:

"Run the Enable Enterprise Geodatabase geoprocessing tool or a Python script to create a geodatabase in the database.".


Whenever I try to run the Enable Enterprise Geodatabase tool, it crashes. Even when I create it as a standalone python script, it crashes python.exe. I tried both Python 64 bit installed by the ArcGIS Server and the Python 32 bit installed by the Desktop. Both of them do not work and crash.


I've manage to take a screen shot in ArcCatalog just before it crashes while running the tool:







I've looked everywhere for a solution and couldn't find any documentation or anyone else who've came across the same issue.


Does anyone has any idea?

Thanks in advance.