AnsweredAssumed Answered

'The field is not nullable' only after turning labels on

Question asked by ben_vk on Mar 30, 2016

Hi All,

 

Problem: when I turn labels on within a feature class with a join, I get the error 'The field is not nullable'.

 

Method:

I have got a Feature class with all properties in my area, these all have a 'parcel_no', these parcels can be joined to an Oracle DB using a simple SQL Query Layer, this is the query:

select 
CAST(mdu_acc AS INT) as PARC_NO
from 
aumememo 
where 
mem_typ = '38'
group by mdu_acc

 

This returns a table which is looking exactly as expected.

No errors appear at this stage.

2016-03-31 105212 Weave_Main.mxd - ArcMap.jpg

 

So i then navigate to my polygon feature class, and create the join to this newly added table, all works fine:

Still no errors appear, and they display perfectly on the map (in red).

 

Next I try to add a label based on the parcel number from the original Polygon Feature Class, very simple:

I press OK, then Bingo, the error appears, but note the labels display perfectly:

 

I have gone and tried to do a simple python label query where it only returns items where fiels is not None, this had no effect at all. I can try turning off the labels in order to remove the error, but this has no effect also.

 

The only way I can get the error to ****** off is by removing the join, then adding the join again. But the second I turn labels on the error re-appears.

 

Has anyone found a solution to this or experienced this before?

 

I am wondering if there is a bug in arc map when creating a join and labeling. I have come across this in the past, but it is not consistent as far as I can tell.

 

Thanks for your time.

 

-Ben

 

Nathan Duncan

Outcomes