AnsweredAssumed Answered

Navigating within portal changes url from https to http

Question asked by Colli on Mar 29, 2016
Latest reply on Mar 29, 2016 by Colli

We are just getting setup with Portal and I'm having some difficulties. I'm guessing my problem is relating to how I have IIS or the self signed cert. setup. I'm kind of new with IIS so this could be very simple.

 

I recognize that using a self signed cert is not best practice for production, but this is just our test env and I am simply trying to get to a point where I can really start playing around with portal, deploying web apps to our local server using our AGS map services.

 

However, I am seeing behavior where I navigate to the my content page https://<webservername>/portal/home/content.html without an issue. No cert warning etc. Then when I click any of the navigation links within Portal, the web address defaults back to http. so the my organization url looks like http://<webservername>/portal/home/organization.html

 

I can fix it by simply adding the "s" after http, to keep moving along, but clearly there is some setting I'm missing. Anyone have an idea of what I'm missing?

Outcomes