AnsweredAssumed Answered

Can not rename Composite Locator with Rename tool

Question asked by michaelchap on Mar 23, 2016
Latest reply on Mar 23, 2016 by Dan_Patterson

I am using ArcMap/Catalog 10.0 Basic.  I have to use (10.0) as the third party has not updated their software to cooperate with 10.1 or higher.

 

I am running processes in Model builder where I am copying gdbs from one folder to another down a line of three of folders as the gdbs are updated.  I need to rename the Composite Locator for each gdb to the next folder name down the line after the gdb is copied over.

 

When I run the Rename tool in Model Builder (or even alone) for the Composite Locator it will not rename. Message Error 99999 comes up.  I have tried running the Rename tool every which way but loose to get it to work, inside the gdb or outside the gdb.  The gdb with Composite Locator to be renamed is not open anywhere to cause a schema lock.

 

I know I can copy the Composite Locator with the new name and then delete the old one, but it seems like a waste of time as that is what the Rename tool is for.  I can not find any information anywhere that Locators can not be renamed with the Rename tool.

 

Am I missing something or Locators can not be renamed with the Rename tool

Outcomes