AnsweredAssumed Answered

Trouble With Arc Hydro Tools: Drainage Line Processing (Delete Field 999999)

Question asked by tibug on Mar 23, 2016
Latest reply on Mar 23, 2016 by tibug

Hello everyone, I think this is my first post here, so I apologize if it is in the wrong spot.

 

I am have some experience with ArcMap (but only just learning Python) from two classes I've taken and self-teaching.  I am brand new to Arc Hydro, and I'm VERY impressed with the features it has.  I have ArcMap 10.3 For Desktop.  Currently I am just trying to run the 'Basic Dendritic Terrain Processing' Model, starting with a filled 10ft DEM of a watershed.

 

Capture.JPG

 

It makes it happily to the Drainage Line Processing Tool, where it hangs up every time, giving these errors:

Error 999999: Cannot delete a field that is part of an index.....

Error HRESULT E_FAIL.....

 

Capture2.JPG

 

It outputs a DrainLine feature class, with very pretty streams.  However, the tool creates a grid_code field in the attribute table which it subsequently attempts to remove, but cannot because it makes the field a key/required field.

 

Capture3.JPG

I can delete the field by using 'Remove Attribute Index' and then just deleting it, but that is only part of the problem.  The Drainage Line Processing Tool is also supposed to create a NextDownID field, which it can't because the tool is stopped by the error.  The NextDownID field is required for the Adjoint Catchment Processing Tool.

 

What I've tried so far:

-Turning it off and on again.

-Uninstalling and reinstalling the latest version of Arc Hydro, 10.3.0.72.

-Everything was being run off a Google Drive folder (unlimited storage).  I tried moving everything to my hard drive and running it from there.

-Clearing my temp folder.

-Changing location of temp folder.

-Changing geodatabases.

 

No change with anything so far.

 

One thing I just thought of while typing this is to run everything in a new MXD...I feel dumb because I didn't think to try that.  I will but I need to run now, so I just want to post this up after writing it all.

 

Any advice would be appreciated.

Outcomes