Quinto

Local Server on Red hat 7.1x64

Discussion created by Quinto on Mar 15, 2016
Latest reply on Mar 16, 2016 by LDanzinger-esristaff

Hello,

 

I'm using the esri QT Runtime 10.2.6 on Red Hat 7.1 x64, with the latest version of qt libraries(5.5). I was trying the example on esri site Dynamic map layer (https://developers.arcgis.com/qt/cpp/sample-code/dynamic_map_layer_sample.htm) and map control does not display anything, those are the results.

Immagine1.png

This is the log file

 

Starting server

Local server process started

'apppid' = '8433'

 

'cleanuponshutdown' = ''

 

'crashdump' = 'full'

 

'datadir' = '/tmp'

 

'enablehtmlviews' = ''

 

'logging' = ''

 

'onlinux' = ''

 

datadir does not exist, creating: "Z:\tmp\arcgisruntime_8"

 

Message : DataDir : Z:\tmp\arcgisruntime_8

 

Enabling logging

 

Message : Log file path : /tmp/ArcGISRuntimeLogs/arcgisruntime_8.log

 

Message : AppDataLocalDir : C:\users\valerio\LO~SSGOF\ArcGISRuntime

 

Message : AppDataRoamingDir : C:\users\valerio\LO~SSGOF\ArcGISRuntime\Roaming

 

Message : AppDataCommonDir : C:\users\valerio\LO~SSGOF\ArcGISRuntime\Common

 

Message : MyDocumentsDir : C:\users\valerio\LO~SSGOF\ArcGISRuntime\Documents

 

Message : CrashDumpPath : Z:\tmp\ArcGISRuntimeErrorReports

 

Message : Licensing level : demo:standard:0

 

2016-03-11 11:57:32,322: INFO  rid=    'server'  WebServer - Starting server on port 50000

 

2016-03-11 11:57:32,322: INFO  rid=    'server'  PionScheduler - Starting thread scheduler

 

2016-03-11 11:57:32,323: INFO  rid=    'server'  WebServer - Added request handler for HTTP resource: /ySbCq9/outputdir

 

2016-03-11 11:57:32,323: INFO  rid=    'server'  WebServer - Loaded static web service for resource (/ySbCq9/outputdir)

 

2016-03-11 11:57:32,323: INFO  rid=    'server'  AdminWebService - Creating.

 

2016-03-11 11:57:32,324: INFO  rid=    'server'  WebServer - Added request handler for HTTP resource: /ySbCq9/arcgis/rest

 

2016-03-11 11:57:32,324: INFO  rid=    'server'  WebServer - Loaded static web service for resource (/ySbCq9/arcgis/rest)

 

2016-03-11 11:57:32,324: INFO  rid=    'server'  WebServer - Added request handler for HTTP resource: /static

 

2016-03-11 11:57:32,325: INFO  rid=    'server'  WebServer - Loaded static web service for resource (/static)

 

Message : Server version : 10.2.6.4161

 

Message : Server listening on : http://127.0.0.1:50000/ySbCq9/arcgis/rest

 

2016-03-11 11:57:34,426: INFO  rid=1   'server'  AdminWebService - POST admin/createService?filePath=/home/valerio/arcgis/runtime_sdk/qt10.2.6/sdk/samples/data/mpks/USCitiesStates.mpk&maxRecords=1000&name=USCitiesStates.mpk&type=MapServer&f=json

 

2016-03-11 11:57:34,428: INFO  rid=1   'server'  mpk - Creating.

 

2016-03-11 11:57:34,428: INFO  rid=1   'server'  mpk - Create

 

2016-03-11 11:57:34,428: INFO  rid=1   'server'  mpk_host - Creating.

 

2016-03-11 11:57:34,432: INFO  rid=1   'server'  mpk_host - Launching.

 

2016-03-11 11:57:34,510: INFO  rid=1   'server'  mpk_host - Launched process 47

 

 

And thi is the local server REST pageImmagine2.png

 

 

 

 

 

what is the problem for you?

 

Thanks

Outcomes