AnsweredAssumed Answered

WAB config changes ignored

Question asked by mhylden on Feb 25, 2016
Latest reply on Feb 25, 2016 by mhylden

I have a custom widget that includes a config.json file in the widget directory.  Changes I have made to the config file (and I have verified that the file is in the right directory) are not being loaded.  My query task fails because the layer index is wrong on the query task, and when I step through in F12 developer tools, it still shows the old layer index when I look at the config values, even though the file has been updated.

I've tried the following to no avail:

cleared browser cache

Shift+F5 to refresh my browser

tried a different browser

tried from a remote desktop on a computer that has never accessed this site

moved the contents of my website to a different directory

replaced the contents with a generic index.html (saw this change on the url)

changed the source directory to the new location, still shows values not in my config file.

 

so is there some other place that the config settings get cached that I'm missing? 

 

Thanks in advance for any ideas.

Outcomes