AnsweredAssumed Answered

Map download failed - certificate for this server is invalid

Question asked by alison_ott on Feb 22, 2016
Latest reply on Apr 17, 2017 by W0194119

We are just trying to get things up and running with Collector but have run into an issue that I am pretty confident has to do some sort of restriction on my network. What we want to do is use our own basemaps and provide users with the ability to work offline.

 

We have modified our existing cached basemap services to allow for the export of tiles.

We can see the .tpk being produced on the server when the iOS Collector app makes the request to download (found the tile package on the server in the ...\directories\arcgisoutput\external\Basemap_Ottawa_MapServer\_agsLMapCacheLFF91)

Unfortunately, when the iPad gets to the point of bringing that .tpk over to the ipad we get the following message.

 

Map Download Failed

Unable to download the map

The certificate for this server is invalid. You might be connecting to a server that is pretending to be "arcgisazureprod.blob.core.windows.net" which could put your confidential information at risk

Would you like to connect to the server anyway?

 

If I select OK, nothing happens.

 

In order to debug we created another collector app that uses a tiled cached service hosted by another organization. Unfortunately, when I try to download the tiles, I get the same certificate error.

 

I then took the ipad home and tried it to download the maps on my home network. There it all worked fine.

 

What I am looking for is an idea of what I need to change. Is this a firewall setting? The server that created the tile package resides inside my network. One thing is that the URL of the service is actually an F5 entry that points to two load balanced servers. But this shouldn't really have any impact since the message is received with services hosted both inside the network and outside the network.

 

Any thoughts and suggestions are appreciated,

     Alison

Outcomes