vsfoote

Error message -- "Unable to prepare your authorization". Caused by FNPLicensingService.exe not being upgraded during 10.4 ArcGIS for Desktop install

Discussion created by vsfoote on Feb 21, 2016

So, a heads-up for Single Use license holders moving to ArcGIS for Desktop 10.4

 

Here is an interesting rub I just had when doing a cleaning and fresh install of ArcGIS for Desktop 10.4-- Esri's installer did not upgrade the FNPLicensingService.exe -- and so failed FlexNet Publisher trusted storage license fulfillment exchanges.  Was able to point the install to an active concurrent license pool, which worked (but the available license status panels in ArcGIS Administrator -> Desktop -> Availability were blank).  Strangely also affected an new installation of CityEngine 2015.2 on the same system--so guess all local Esri, e.g. <Publisher><Name>ArcGIS</Name><Products>...,  FNP services were affected.

 

Fortunately a simple work around to force the upgrade by installing the ArcGIS License Manager (even though it is not otherwise needed)  and then uninstall it.  And with the correct FNP 11.13.1.2 version component in place, can then complete the Single Use FNP authorization fulfillment exchanges.  This will work until Esri can patch the installer.

 

Just filed this support ticket...

 

<quote>

On system with other FNP licensed software, installation of ArcGIS for Desktop 10.4 does not update the running FlexNetPublisher licensing service during install. A FNP 11.12.1.2 existing version of FNPLicensingService.exe remains installed to C:\Program Files (x86)\Common Files\Macrovision Shared\FLEXnet Publisher rather than the required 11.13.1.2 version.

 

The resulting mismatch in FNP licensing libraries causes attempts to exchange authorization fulfillments to fail repeatedly with trusted storage event log entries similar to these.

 

13:19:59 21-02-2016 [P:7068],[T:384],[V:11.13.1.2 build 173302] Exception: 44, Module: b0000, Location: 1, Internal: 10103

13:19:59 21-02-2016 [P:7068],[T:384],[V:11.13.1.2 build 173302] EventCode: 2000000a, Message: Incorrect version of the service installed

13:19:59 21-02-2016 [P:7068],[T:384],[V:11.13.1.2 build 173302] EventCode: 2000000a, Message: Incorrect version of the service installed

 

=-=-=

Workaround

 

Installing the FlexNet Publisher 11.13.1.2 based ArcGIS License Manager (ArcGIS_License_Manager_Windows_104_149423.exe) replaces the incorrect FNPLicensingService.exe. And the License Manager can then be uninstalled.

</quote>

 

Message was edited by: V Stuart Foote -- clarity.

Outcomes