cshiel

How to recompile CGB

Discussion created by cshiel on Feb 21, 2016
Latest reply on Feb 25, 2016 by rathiabhishek

I am using the sample prt4cmd from the SDK and getting this error. I am using the sample data (candler.rpk + candler.obj) provided.It is complaining that I need to recompile the CGB. How can I do this?

 

This is the error message:

C:\esri-cityengine-sdk-master\examples\prt4cmd\install\bin>prt4cmd -s 27000@Chris-Dev -f CityEngAdv -l 3 -g C:/esri-city

engine-sdk-master/examples/prt4cmd/install/bin/data/candler_lot.obj -p C:/esri-cityengine-sdk-master/examples/prt4cmd/in

stall/bin/data/candler.rpk -a ruleFile:string=bin/candler.01.cgb -a startRule:string=Default\$Lot -e com.esri.prt.codecs

.OBJEncoder -z baseName:string=theCandler

[2016-Feb-22 11:14:48.494413] [warning] CGB file contains warning 'Potentially problematic CGAC version 1.2 : recompilin

g with current CGA Compiler (1.5) is recommended.'

[2016-Feb-22 11:14:48.501405] [error] OBJEncoder::encode failed, exception caught: 'Unknown rule.'

[2016-Feb-22 11:14:48.504408] [error] Status code = 37 = Unknown rule.

Outcomes