AnsweredAssumed Answered

Anaconda interfering with running spatial statistics in ArcMap 10.2

Question asked by eric.eagle on Feb 11, 2016
Latest reply on May 19, 2016 by Dan_Patterson

Hi Python group,

 

I'm running ArcGIS 10.2 with 64bit background geoprocessing. I've also got Anaconda 64bit configured as my preferred interpreter.  I can write in Spyder and call arcpy, no problems there.

 

My problem is that now, when I run spatial statistics scripts, it will error out.  I tried running optimized hot spot analysis today and it gave me this:

 

Trackback (most recent call last):

     File "c:\program files (x86)\arcgis\desktop10.2\ArcToolbox\Scripts

\OptimizedHotSpotAnalysis.py", line 30, in <module>

          import MoransI_Increment as MI

     File "c:\program files (x86)\arcgis\desktop10.2\ArcToolbox\Scripts

\MoransI_Increment.py", line 24, in <module>

          import pylab as PYLAB

     File "C:\Python27\ArcGIS10.2\lib\site-packages\pylab.py", line 1, in <module>

          from matplotlib.pylab import *

     File "C:\Python27\ArcGIS10.2\lib\site-packages\matplotlib\__init__.py", line

134, in <module>

          from matplotlib.rcsetup import (defaultParams,

     File "C:\Python27\ArcGIS10.2\lib\site-packages\matplotlib\rcsetup.py", line 18,

in <module>

          from matplotlib.fontconfig_pattern import parse_fontconfig_pattern

     File "C:\Python27\ArcGIS10.2\lib\site-packages\matplotlib

\fontconfig_pattern.py", line 23, in <module>

          from matplotlib.pyparsing import Literal, ZeroOrMore, \

     File "C:\Python27\ArcGIS10.2\lib\site-packages\matplotlib\pyparsing.py", line

71, in <module>

          import xml.sax.saxutils

     File "C:\Users\eagle\AppData\Local\Continuum\Anaconda\Lib\xml\sax

\saxutils.py", line 6, in <module>

          import os, urlparse, urllib, types

     File "C:\Users\eagle\AppData\Local\Continuum\Anaconda\Lib\urllib.py", line

26, in <module>

          import socet

     File "C:\Users\eagle\AppData\Local\Continuum\Anaconda\Lib\socket.py", line

47, in <module>

          import _socket

ImportError: DLL load failed: %1 is not a valid Win32 application.

 

So here's what confuses me. Why is it summoning a 32 bit DLL if I have 64 bit background geoprocessing installed?

 

Ideally I would like to keep Anaconda on my system.  Is there a way for me to point ArcMap back to the 32 bit interpreter for the purposes of the toolbox scripts?

 

Thanks for any assistance!

Outcomes