AnsweredAssumed Answered

"Cached" layer/sublayer visibility settings in WAB 1.3 apps calling AGOL Web Maps - MAJOR BUG?

Question asked by brESRI on Feb 11, 2016
Latest reply on Mar 24, 2016 by kmsagis

In apps made with WAB 1.3 (AGOL) and WAB Developer Edition 1.3, zoom level, geographic location, and layer visibility settings are saved in the browser "data cache" (?) across browser viewing sessions.  These settings are maintained even if browser data and memory caches are cleared.  This major change was apparently conceived as a nifty way to allow users to "resume" viewing sessions.

 

I have an AGOL Web Map with many layers.  These layers have very complex visibility settings for sublayers, sub-sub layers, etc.  These visibility settings were set in the mxds before the services were published.  I have not changed any of those settings in the Web Map.

 

I noticed today that if a user toggles layer and sublayer visibility in an app in a browser, closes the browser, reopens it, and returns to the app, ALL layer/sublayer/sub-sublayers in the app are TURNED OFF except for the ones which were on when the previous session was closed.  This unfortunate, show-stopping problem occurs in WAB apps generated on AGOL or WAB Dev 1.3 which call the AGOL Web Map.

 

It appears to me that the visibility settings of ALL layers/sublayers in the app should be saved to the "data cache," not just the settings of the layers which happened to be toggled on when the app viewing session closed.  Or, there should be a "Reset" button in the app which resets it to "factory default" settings in all regards.

 

This show-stopper of a problem is preventing me from distributing links to WAB 1.3 apps which call AGOL Web Maps.  All WAB 1.2 apps are fine in this regard.

 

Is this a bug, or is there a simple workaround that would enable a user to reset the app's layer visibility settings to the default (meaning those shown in the Web Map)?

Outcomes