AnsweredAssumed Answered

Copy parallel not preserving attributes and also crashing at times

Question asked by infobleep on Feb 8, 2016

Hi there

 

I'm trying to copy a road centre line so that I have a left and right footway. This is in a file geodatabase but the centre road lines come originally from an ArcSDE database.

 

To do this I am using copy parallel as it needs to be linked to an Excel Spreadsheet and representations only work with feature classes.

 

Previously I had managed to do this. Today I was about to do the right hand side and create a feature class with the attributes preserved.

 

However when I tried to do the same to the left hand side I could not get the attributes to come across.

 

As soon as I select more than one line, the option, Treat section as a single line is greyed out. However if it's not possible to have this option available when select multiple lines,  how come I was able to get the right hand side to be created with the attribute information intact.

 

I am using ArcMap 10.0 but I tired it in version 10.3.1 and I'm having the same issues.

 

Also ArcMap 10.0 kept crashing without errors. I think the issue occurs when a line length becomes less than 0. I found this didn't occur in version 10.3.1 and I actually got an error message. Although that didn't explain what was causing the issue. However at least I didn't need to restart ArcMap, which at times can be a slow process on my computer. I was thus able to find the offend row and deal with it manually. However the attributes issue was still present for everything else.

 

Thanks for your help

 

Tim

Outcomes